Bank transfers are running late for some customers
Incident Report for Dojo
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 15:39 GMT
Investigating
We're aware that bank transfers are running late for some customers. We're on it and working to get funds to you as soon as possible. We’ll add any updates to this page as they happen.

Thanks for your patience.
Posted Jan 26, 2023 - 11:38 GMT
This incident affected: Transfers.