Today's bank transfer
Incident Report for Dojo
Resolved
All funds for transactions taken on Saturday 24 September have now been processed. Please allow a few hours for the funds to reach your bank account.

Thank you for your patience as our team worked to resolve this.
Posted Sep 25, 2022 - 13:57 BST
Identified
Daily bank transfers might be delayed for some businesses today. We’re on it and working as quickly as possible to get all funds transferred. We’ll add any updates to this page as they happen.

Thanks for your patience.
Posted Sep 25, 2022 - 12:07 BST
This incident affected: Transfers.