Bank transfers are running late for some customers
Incident Report for Dojo
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 19:35 BST
Monitoring
We're aware that bank transfers are running late for some customers. The funds are on their way but may take a few hours to reach your bank account.
Posted Sep 27, 2022 - 16:23 BST
This incident affected: Transfers.