Your bank transfer may be later than usual today
Incident Report for Dojo
Resolved
This incident has been resolved.
Posted Jun 18, 2023 - 14:04 BST
Investigating
Some customers might receive their bank transfer from Dojo later than usual today.
We're working to send your funds and update the transfer status in your Dojo app as soon as possible.
Thanks for your patience.
Posted Jun 18, 2023 - 11:53 BST
This incident affected: Transfers.