Today’s bank transfer may be less than expected or delayed for some customers

Degraded performance Dojo UK Transfers
2023-12-30 14:21 BST · 22 hours, 26 minutes

Updates

Resolved

All delayed and missing transfers have now been paid to any impacted customers.

December 31, 2024 · 12:47 BST
Update

For some customers impacted by the delayed transfers, these are now being processed and should be in your bank account shortly.

For some customers impacted by the missing transfers, we are still working hard to get these to you as quickly as possible.

We’ll update this page with any updates.

December 31, 2023 · 16:15 BST
Investigating

Some customers might notice that today’s bank transfer is either delayed or is less than expected.

Our team are working to get the missing funds to you as quickly as possible.

We’ll update this page with any updates.

December 31, 2023 · 14:21 BST

← Back