Bank transfers are running late for some customers

Degraded performance Dojo UK Transfers
2024-06-09 12:12 BST · 2 hours, 9 minutes

Updates

Resolved

This incident has now been resolved.

June 9, 2024 · 14:21 BST
Investigating

We are aware that some customers may be experiencing delays receiving their transfers. We’re looking into it and will post updates as we know more.

We are aware that occasionally payments can take their time to work through the banking system so please continue to check your account. To understand more please go to Support.dojo.tech and search “How we transfer your takings”.

June 9, 2024 · 12:12 BST

← Back