Bank transfers are running late

Degraded performance Dojo UK Transfers
2024-09-25 09:04 BST · 6 hours, 41 minutes

Updates

Resolved

All funds have now been sent. Please allow a few hours for the funds to reach your account.

September 25, 2024 · 15:37 BST
Monitoring

Transfers are back up and running.
We’re now transferring funds to anyone affected.

September 25, 2024 · 11:07 BST
Investigating

Transfers will be with you soon.

Some businesses have not yet received their bank transfers for today. We’re on it and working as quickly as possible to get all funds transferred.

Thanks for your patience.

September 25, 2024 · 09:04 BST

← Back