Transfers will be with you soon.
Degraded performance
Dojo Spain
Transfers
2024-11-24 09:30 GMT
· 1 day, 5 hours, 8 minutes
Updates
Resolved
November 25, 2024 · 14:37 GMT
Transfers are now being processed.
All funds have now been sent. Please allow a few hours for the funds to reach your account and the transfer status in your Dojo account to update.
Monitoring
November 25, 2024 · 10:16 GMT
Transfers are back up and running.
We’re now transferring funds to anyone affected.
Investigating
November 24, 2024 · 13:57 GMT
Some businesses may not yet have received today’s bank transfers. We’re on it and working as quickly as possible to get all funds transferred. Thanks for your patience.
← Back