Call not connecting?

Major outage Dojo UK Customer support Dojo Ireland Customer support Dojo Spain Customer support
2025-01-29 07:45 GMT · 3 hours, 34 minutes

Updates

Resolved

This issue is now fixed.

January 29, 2025 · 11:18 GMT
Monitoring

Calls are now connecting successfully.

Thanks for your patience.

January 29, 2025 · 09:21 GMT
Issue

We are currently experiencing technical difficulties with our phone lines.

If you need immediate assistance, please email us at ‘support@dojo.tech’ or use our webchat.

We’re working on it urgently to get everything back up and running. Sorry for the inconvenience.

January 29, 2025 · 08:33 GMT

← Back