DCC Transactions Outage

Major outage Dojo UK In-person Payments Dojo Go Dojo Ireland In-person Payments Dojo Go Dojo Spain In-person payments Dojo Go
2025-02-14 11:45 GMT · 1 hour, 41 minutes

Updates

Resolved

The third-party outage has been resolved and DCC payments can now be taken as normal. We apologise for any inconvenience this outage may have caused and appreciate your patience.

February 14, 2025 · 13:40 GMT
Issue

Due to a third-party outage, Dynamic Currency Conversion (DCC) is temporarily unavailable on enabled card machines. Cardholders can still make payments, but DCC will not be offered. This means that all payments will be processed in the card issuer’s home currency.

February 14, 2025 · 13:00 GMT

← Back