Some transfers are delayed

Partial outage Dojo UK Transfers Dojo Ireland Transfers Dojo Spain Transfers
2025-04-21 11:02 BST · 2 hours, 5 minutes

Updates

Resolved

All funds have now been sent. Please allow a few hours for the funds to arrive in your account. We’re sorry for any disruption caused and appreciate your patience.

April 21, 2025 · 13:00 BST
Issue

Merchants who receive transfers via YouLend are currently experiencing delays. We will provide an update on these transfers and estimated arrival times as soon as we have more information.

April 21, 2025 · 11:02 BST

← Back