Card machine activation

Degraded performance Dojo UK In-person Payments Dojo Go Dojo Wired Dojo Ireland In-person Payments Dojo Go Dojo Wired Dojo Spain In-person payments Dojo Go Dojo Wired
2025-04-25 17:30 BST · 53 minutes

Updates

Resolved

The activation service has been restored. You may now retry any activations that were unsuccessful.

April 25, 2025 · 18:16 BST
Issue

Some customers are currently experiencing difficulties activating new Dojo card machines due to a problem with a third-party provider. Our team is working with the provider to resolve this issue.

In the meantime, if you have an already activated Dojo card machine, please use it. We appreciate your patience as we work to fix this.

April 25, 2025 · 17:30 BST

← Back