Delay with Transfers to Ireland, Spain, and Italy

Degraded performance Dojo Ireland Transfers Dojo Spain Transfers Dojo Italy Transfers
2025-06-26 10:15 BST · 2 hours, 23 minutes

Updates

Resolved

All transfers affected by the delay to Ireland, Spain, and Italy have now been successfully sent.

Please allow a few hours for the funds to reflect in your bank account. Thank you for your patience.

June 26, 2025 · 12:38 BST
Investigating

We are currently experiencing a delay with sending some transfers to customers in Ireland, Spain, and Italy. We are working to resolve this as quickly as possible and apologise for any inconvenience.

We’ll provide an update here as soon as we have more information.

June 26, 2025 · 10:15 BST

← Back