EE 4G Network Issue Affecting Card Machine Connectivity

Partial outage Dojo UK In-person Payments Dojo Go Dojo Pocket
2025-07-25 11:58 BST · 1 hour, 38 minutes

Updates

Resolved

The earlier issue affecting some card machines using 4G mobile data via EE has now been resolved. Devices should now be able to connect to the EE network and process payments as normal.

If you’re still experiencing connectivity issues, we recommend restarting your device or phoning our Customer Support Team for further assistance.

Thank you for your patience while this external issue was being resolved.

July 25, 2025 · 13:35 BST
Investigating

Some card machines using 4G mobile data via EE are currently unable to connect to the network due to a widespread issue affecting EE’s 4G data services.

If you’re affected, you can switch to another mobile network. Please see our Help Centre for guidance: Troubleshooting Connectivity Problems

July 25, 2025 · 11:58 BST

← Back