Partial Settlement Disruption

Degraded performance Dojo UK Transfers Dojo Ireland Transfers Dojo Spain Transfers
2025-09-29 10:08 BST · 2 hours, 27 minutes

Updates

Resolved

The issue affecting merchant settlements has been resolved, and all pending settlements have been completed.
We apologise for the disruption and thank all affected merchants for their patience.

September 29, 2025 · 12:32 BST
Issue

Some merchants are currently experiencing a temporary delay in settlements due to an issue with a third-party banking partner. Our teams are closely monitoring the situation and will provide updates as soon as more information becomes available. We apologise for any inconvenience this may cause.

September 29, 2025 · 10:08 BST

← Back