Temporary Delay in Merchant Settlements
Degraded performance
Dojo UK
Transfers
Dojo Ireland
Transfers
Dojo Spain
Transfers
2025-10-04 11:06 BST
· 2 hours, 39 minutes
Updates
Resolved
October 4, 2025 · 13:44 BST
The issue impacting merchant settlements has been resolved, and all pending payments have been sent.
Thank you for your patience while we worked with our banking partner to restore operations.
Issue
October 4, 2025 · 11:06 BST
We are aware that some merchants are experiencing a temporary delay in settlement payments resulting from an issue with one of our banking partners. Our teams are in close contact with the provider and are monitoring the situation closely. Further updates will be provided as soon as additional information is available.
← Back