Issues with UK Inbound Phone Support (Emergency Line Available)

Degraded performance Dojo UK Customer Support
2026-05-25 09:35 BST · 1 hour, 4 minutes

Updates

Resolved

The routing issue affecting our primary UK support line (0800 044 3550) has been successfully resolved. Inbound calls are now correctly routing to our technical support team as intended.

The emergency secondary number has now been deactivated. We appreciate your patience during this disruption and apologise for any inconvenience caused to your support experience.

May 25, 2026 · 10:39 BST
Investigating

We are currently experiencing a routing issue with our primary UK support line (0800 044 3550), causing calls to unexpectedly disconnect after the greeting.

If you are a UK customer requiring urgent technical support, please dial our secondary line at +44 20 4632 4007.

We apologise for the disruption and are actively working on a fix for the primary line.

May 25, 2026 · 09:35 BST

← Back