Mastercard Online Payment Disruption

Partial outage Dojo UK Remote Payments Online Checkout Payment Links
2026-07-15 09:32 BST · 2 hours, 59 minutes

Updates

Resolved

We have observed that Mastercard transaction traffic has stabilised and returned to normal levels. We will continue to monitor the situation closely to ensure ongoing stability.

July 15, 2026 · 12:25 BST
Issue

We are aware of a network issue with Mastercard that is causing some online payments to fail at checkout. This is due to a service disruption on Mastercard’s side. Payments made with other card networks (such as Visa) and digital wallets (like Apple Pay or Google Pay) are working normally.

Our teams are actively monitoring the situation as Mastercard works to resolve the issue, and we will update this page as soon as services are fully restored.

July 15, 2026 · 09:32 BST

← Back