Delays on UK Faster Payments System
Degraded performance
Dojo UK
Transfers
2026-07-27 16:29 BST
· 1 hour, 18 minutes
Updates
Resolved
July 27, 2026 · 17:46 BST
All Payments Processed: All queued transfers have now been successfully sent to receiving banks and our processing queues are fully clear. Thank you for your patience!
Issue
July 27, 2026 · 16:29 BST
An external Faster Payments issue is currently causing processing delays and timeouts for transfers to select UK banks. Payments are continuing to process, but at a reduced speed.
Our teams are monitoring the situation, and we will share an update once processing times return to normal.
← Back
Dojo Ltd Status