Payment Processing Issues on Dojo Duo & Dojo Pocket Terminals

Major outage Dojo UK In-person Payments Dojo Pocket Dojo Ireland In-person Payments Dojo Pocket Dojo Spain In-person payments PAX Terminals Dojo Pocket Dojo Italy In-person Payments Dojo Pocket
2026-09-13 09:03 BST · 2 hours, 33 minutes

Updates

Resolved

The fix has been applied, and payment processing is now fully restored across all affected devices.

We apologise for the inconvenience caused and thank you for your patience.

September 13, 2026 · 11:36 BST
Investigating

Work to deploy the fix is currently ongoing to restore full payment processing on all affected devices as quickly as possible.

If your business has Dojo Go devices available, please continue to use them as a temporary alternative.

September 13, 2026 · 11:32 BST
Investigating

We have identified the issue affecting Dojo Duo and Dojo Pocket devices. Our teams are actively deploying a fix to restore full payment processing as quickly as possible.

September 13, 2026 · 10:22 BST
Investigating

We are currently investigating reports of payment transaction failures affecting merchants using Dojo Duo and Dojo Pocket terminals.

If your business has Dojo Go devices available, please use them as a temporary alternative to process payments.

September 13, 2026 · 09:03 BST

← Back