Investigating issues with customer support phone lines

Partial outage Dojo UK Customer Support Dojo Ireland Customer Support Dojo Spain Customer support Dojo Italy Customer Support
2026-09-16 09:48 BST · 9 hours, 1 minute

Updates

Resolved

The technical issue affecting our phone system has been resolved, and calls are connecting to our support team as normal. You can once again reach us by phone or continue to contact us via support@dojo.tech.

Thank you for your patience while we worked to resolve this.

September 16, 2026 · 18:48 BST
Investigating

We are currently experiencing technical issues impacting our inbound customer support phone lines. During this time, callers will hear an automated system message, and phone calls may not be able to connect to our support team.

Our engineering team is investigating the issue to restore full phone service as quickly as possible.

In the meantime, our team is standing by to help you via email. If you need assistance, please submit your request to support@dojo.tech, and we will respond as soon as possible.

We apologise for any inconvenience this may cause and appreciate your patience while we work on a resolution.

September 16, 2026 · 09:48 BST

← Back