Virtual Queues and Bookings - Webchat not working
Incident Report for Dojo
Resolved
This incident has now been resolved.
Posted Oct 12, 2023 - 17:05 BST
Identified
We're aware that some customers with Virtual Queues and Bookings are unable to contact us at the moment. Our technical parters are working to fix this as soon as possible. If you need to contact us please call us on 0800 044 3550.
Posted Oct 12, 2023 - 16:25 BST
This incident affected: Customer support.