Bank transfers might be running late for some customers
Incident Report for Dojo
Resolved
All funds have now been sent. Please allow some time for the funds to reach your account and the transfer status in your Dojo account to update.
Posted Apr 16, 2024 - 09:47 BST
Investigating
We are aware that some customers may be experiencing delays receiving their transfers. We're looking into it and will post updates as we know more.

We are aware that occasionally payments can take their time to work through the banking system so please continue to check your account. To understand more please go to Support.dojo.tech and search “How we transfer your takings”.
Posted Apr 16, 2024 - 09:02 BST
This incident affected: Transfers.