Today’s bank transfer might be less than expected for some customers
Incident Report for Dojo
Resolved
This incident has been resolved.
Posted Aug 03, 2023 - 17:36 BST
Investigating
Today's bank transfers might be less than expected for some businesses. We’re on it and working as quickly as possible to get all funds transferred. We’ll add any updates to this page as they happen. Thanks for your patience.
Posted Aug 03, 2023 - 15:24 BST
This incident affected: Transfers.